Home Videos Games Podcastle

Forum Bug reports


#21

Just found one more thing, not really a bug just an oddity. Some of the URL’s are a bit weird for the thread pages:

  • Roleplaying Games - https://www.shutupandsitdown.com/forums/#/categories/podcast-threads
  • THE PURCHASE CHAMBER - https://www.shutupandsitdown.com/forums/#/categories/video-threads
  • Help / Advice Forum - https://www.shutupandsitdown.com/forums/#/categories/ron-paul-2012!

I get that this probably can’t be fixed, but some of the URLs could certainly lead to confusion.


#22

Firefox 32.0.2, Windows 8

I use NoScript in Firefox (v2.6.8.41). I have it set to allow scripts, but it still has a bunch of safety features. It keeps intermittently flagging the navigation links at the top of the forum as clickjacking attempts when the header (logo) bar is partially overlapping the navigation links. This is basically my own fault but I thought you might like to be aware since other security software might flag it also.

Text of the warning:
“Potential Clickjacking/UI Redressing Attempt!
NoScript intercepted a mouse or keyboard interaction with a partially hidden element.”


#23

yet another minor bug from me (sorry) if you post on a user’s “wall” the post that says “Not much happening here, yet.” remains on the page below your recent comment. This initially lead me to believe that the something was going wrong and the server was struggling to record my action or something (I then refreshed the page and understood).
Once again a minor issue that is probably more trouble to fix than it causes but just wanted it reported.
Cheers.


#24

dontneedaclassroom: I don’t think there’s anything we can do about that, but as you say it’s good to know in case it comes up again.
JakeThePirate: We’re looking at the activity and post-edit functions at the moment, should be updating soon. The links are weird aren’t they? Holdover from the suggested defaults I think, but who knows!

Thank you both for the feedback!


#25
So there's a preference option for notification about bookmarked discussions, but there doesn't seem to be a way to add a bookmark to a thread outside of using browser bookmarks. Does the forum read our browser information, or are we missing a flag on the discussions themselves?

Just reviewing this threat and realised that I never responded to this, sorry Elbast!
The bookmark it refers to is the star icon on the right hand side. Click that to bookmark it!


#26
So there's a preference option for notification about bookmarked discussions, but there doesn't seem to be a way to add a bookmark to a thread outside of using browser bookmarks. Does the forum read our browser information, or are we missing a flag on the discussions themselves?

Just reviewing this threat and realised that I never responded to this, sorry Elbast!
The bookmark it refers to is the star icon on the right hand side. Click that to bookmark it!

No problem! I found the answer in the sticky after posting :smile:


#27
  • Help / Advice Forum - https://www.shutupandsitdown.com/forums/#/categories/ron-paul-2012!

    I get that this probably can’t be fixed, but some of the URLs could certainly lead to confusion.

  • …or to the election of the leading US libertarian candidate due to the actions of subliminally-suggestable SUSD-reading timetravelers?


    #28

    Is the “LOL” button just a styling/design thing? I don’t think LOL is very SU&SD, although I’m not sure what our alternative should be.


    #29
    Is the "LOL" button just a styling/design thing? I don't think LOL is very SU&SD, although I'm not sure what our alternative should be.

    I know what you mean, but anything better (that I can think of anyway) is a bit long. Chortle maybe? I’ll stick it on the bug tracker so we can find out if it’s even possible. Anyone else have any better ideas in the mean time?


    #30
    Is the "LOL" button just a styling/design thing? I don't think LOL is very SU&SD, although I'm not sure what our alternative should be.

    I know what you mean, but anything better (that I can think of anyway) is a bit long. Chortle maybe? I’ll stick it on the bug tracker so we can find out if it’s even possible. Anyone else have any better ideas in the mean time?

    I think LOL or one of the many laughter onomatopoeia would be best. Ha! Heh. Heehee. Bwahahaha. Hahaha. HO. HO. HO. Or just that little happy smiley face it has already without text. :slight_smile:

    I suppose we could go full-on Paul and Quinns with something like “A Joke!” but that has this undercurrent of not-quite-sarcasm that while very SU&SD isn’t quite appropriate in context.

    You know, maybe just Laugh or Laughing or Laughter.


    #31

    When previewing a post for a new thread (not a comment in an existing thread) the headings appear different in the preview to how they will appear when posted. In the preview a h1 heading has a horizontal line underneath it, but this is not there when posted and the text appears to change size (and perhaps font, I’m not sure).
    Once again a minor bug but reporting it all the same.


    #32

    Can you (temporarily?) disable the “responsive” design for the forum pages until you get it fixed so it doesnt show “small device support soon” ? It won’t even render for me on my Macbook Air unless I maximize the window :frowning:


    #33

    Minor (but annoying bug) in Chrome:

    When a page is opened in a new tab with unread posts it has a #latest anchor. However, after the page does its “wait for it” thing, the browser is at the top of the page.

    Edit: I can’t believe I used the wrong “its” :s


    #34
    Can you (temporarily?) disable the "responsive" design for the forum pages until you get it fixed so it doesnt show "small device support soon" ? It won't even render for me on my Macbook Air unless I maximize the window :(

    The tech and design wizards are working on this issue. There are still a few problems with the small devices design.


    #35
    Minor (but annoying bug) in Chrome:

    When a page is opened in a new tab with unread posts it has a #latest anchor. However, after the page does it’s “wait for it” thing, the browser is at the top of the page.

    Added to the bug tracker, thanks!


    #36
    The tech and design wizards are working on this issue. There are still a few problems with the small devices design.

    Strange - when I jump right into a thread with my Galaxy S5 I can read them just fine (haven’t tried writing with the phone yet). I see no problems whatsoever?!


    #37

    I think the issues are with iOS specifically. When I’ve been messing around on the forums with my iPhone the forum hasn’t properly indicated with threads had new posts, among other things.


    #38
    The tech and design wizards are working on this issue. There are still a few problems with the small devices design.

    Strange - when I jump right into a thread with my Galaxy S5 I can read them just fine (haven’t tried writing with the phone yet). I see no problems whatsoever?!

    On my laptop, if you make the window narrow enough that the site thinks it should switch to a mobile layout, the forum disappears entirely and is replaced by “coming soon!” text. The iPhone browser horizontal dimension is always narrow enough to be in this mode and there is no way to “resize” it bigger so you can’t even view the forum at all.


    #39

    New bug, this on’s a bit serious. I’ve got a private message discussion with someone that no longer displays for either of us, I think that it might be due to the number of messages exchanged, perhaps it’s trying to display a new page but does not display any page navigation options.


    #40
    New bug, this on's a bit serious. I've got a private message discussion with someone that no longer displays for either of us, I think that it might be due to the number of messages exchanged, perhaps it's trying to display a new page but does not display any page navigation options.

    Oh man, that sounds bad! I’ll report it to the TechMages straight away.